Latest Addition ==> Bob.Omb's Modified Win10PEx64 v4.7 - RS5

Author Topic: TheOven_Startup.cmd not run anymore?  (Read 149 times)

SteveSi

  • Newbie
  • *
  • Posts: 4
    • View Profile
TheOven_Startup.cmd not run anymore?
« on: December 09, 2018, 03:45:40 am »
I think some previous versions used to automatically run \TheOven_Startup.cmd when the Desktop was reached because I asked Bob to include the WinBuilder module a while ago. However, recent builds don't seem to include it any more?

It could be easily added to the \Autorun.cmd file perhaps (not commented out) so you don't have to remember to include the module in the build? e.g.

Code: [Select]
FOR %%D IN (A B C D E F G H I J K L M N O P Q R S T U V W X Y Z) DO call %%D:\TheOven_Startup.cmd  > nul 2>&1
« Last Edit: December 14, 2018, 10:28:38 am by SteveSi »

SteveSi

  • Newbie
  • *
  • Posts: 4
    • View Profile
Re: TheOven_Startup.cmd not run anymore?
« Reply #1 on: December 09, 2018, 03:50:28 am »
P.S. for those that don't know, adding PEStartup (via TheOven_Startup.cmd or \Auto.cmd) allows you to change the WinPE wallpaper, add Desktop Shortcuts, drivers and registry tweaks automatically to any WinPE without needing to change the ISO\WIM file or manually add files.
See https://www.rmprepusb.com/tutorials/143_pestartup

This means you can run any WinPE (Bob's, Strelec, Falcon F4, DLC, Hirens, etc.) and it will always have the Desktop shortcuts, wallpaper and apps that you want automatically installed.
« Last Edit: December 09, 2018, 03:52:52 am by SteveSi »

Bob.Omb

  • PE Baker
  • Administrator
  • Jr. Member
  • *****
  • Posts: 82
    • View Profile
Re: TheOven_Startup.cmd not run anymore?
« Reply #2 on: December 09, 2018, 09:57:38 am »
This was converted to AutoRun.CMD for ease of use with all users..

You can rename your oven startup cmd to autorun.cmd and replace the included autorun.cmd at the root of our USB.

It is the same exact mechanism... just a different file name..

SteveSi

  • Newbie
  • *
  • Posts: 4
    • View Profile
Re: TheOven_Startup.cmd not run anymore?
« Reply #3 on: December 14, 2018, 10:17:37 am »
No - it is not the same mechanism as TheOven_Startup.cmd plugin uses!

The original WinBuilder plugin causes all drives in the system to be searched for \TheOven_Startup.cmd and then executes it.

This means that I can boot WinPE from an ISO file on Easy2Boot, or boot WinPE from a hard disk with two partitions and it will find TheOven_Startup.cmd on the 2nd partition (which is where my portable apps are) and execute it.

For instance, with an Easy2Boot USB drive, I can have all my portable apps, PEStartup.exe and \TheOven_Startup.cmd on the same partition with a bunch of WinPE ISOs. I can boot any one of the WinPE WinBuilder ISOs and they automatically run \TheOven_Startup.cmd even though I have booted from the ISO file (if they included the plugin in the build).

Also, I can convert each WinPE ISO to a .imgPTN file and have my portable apps, PEStartup and \TheOven_Startup.cmd files on the 2nd partition. This means any WinPE .imgPTN file that I select and boot to (UEFI or MBR) will automatically run \TheOven_Startup.cmd from the 2nd partition.

This is really useful, because any WinPE will automatically give me the Desktop wallpaper, shortcuts, portable apps, etc. that I want.

Could you please add code into \autorun.cmd so it looks for and executes \TheOven_Startup.cmd please? i.e. put it inside the ISO. So that when we boot to the ISO (or flat file folder) it executes it.


« Last Edit: December 14, 2018, 10:31:06 am by SteveSi »